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1 Introduction 
 

Carlson SurveyGNSS provides a robust post-processing environment for computing high 
quality vectors and resultant positions using simultaneous code and carrier phase 
observations of pairs of Global Navigation Satellite Systems (GNSS) receivers. Satellite 
constellations and signals provided by the United States NAVSTAR GPS, Russian 
Federation GLONASS, and various satellite based augmentation systems (SBAS) are 
supported using either single or dual frequency receiver equipment. 
 
 
Carlson SurveyGNSS at a glance: 

- Supports differential post-processing of RINEX GNSS observations in static, ‘stop and 
go’ and kinematic positioning modes. 

- Accepts GNSS observations from any GNSS receiver in RINEX format. 
- Accepts proprietary GNSS observations in the following formats: 

 Carlson .log and .rw5 

 NovAtel .log 

 NVS Technologies .nvs 

 Hemisphere GNSS .bin 

 Altus .sbf 

 Javad .jps 

 Sokkia .pdc 

 Leica .m00, lb2 

 Trimble .dat, t00, t01, t02 

 Conversion of other proprietary manufacturer formats has been 
externalized via shell scripts to allow users to configure and add support 
for command line RINEX conversion utilities. 

- Provides a straightforward, workflow oriented user interface including an overview map 
and observation files, computed vectors, and positions presented in fully functional 
spreadsheet like grids. 

- Incorporates a proven state of the science, highly autonomous baseline processor 
offering on the fly ambiguity resolution, automated cycle slip detection/removal, and 
more for baselines up to 200km (125mi). 

- Automated search and retrieval of reference geodetic control and GNSS observations 
from organizations such as the US National Geodetic Survey and Continuously 
Operating Reference Station (CORS) networks. 

- Rigorous least squares adjustment of all computed vectors. 
- Seamless integration with downstream applications from Carlson and other vendors. 

 
 
In spite of the popularity of real time GNSS surveys,  post-processing field data is still in use 
for various reasons: 

- As a back-up for RTK in case your data link fails (radio range). 
- As a back-up when the RTK network in your area is temporarily out of order 

(GPRS/EDGE congestion). 
- To carry out sub-centimeter geodetic surveys (i.e. deformation analysis). 
- To improve the accuracy of real time single frequency GIS data. 
- To have a backup for critical projects. 
- As a means for Quality Control for real time surveys. 

 
Carlson SurveyGNSS is a reliable and precise tool for all your post-processing applications. 
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2 Registration 
 

Each Carlson program is licensed for use on one workstation which must be registered. The 
registration records your company name and serial number. To register your copy, install and 
then start Carlson SurveyGNSS. When you start the software for this first time after 
installation a window will pop up asking you for your serial number. The serial number 
consists of a 4 groups of characters separated by a dash (-).   
 

 
 
Enter your serial number and press OK.  
 

 
 
There are four registration options. 

- Fax: This method allows you to print out the required information on a form which you 
then fax to Carlson Software. The fax number is printed on the form. The change key 
will be faxed back to you within 72 hours. 

- Internet: Register automatically over the Internet. Your information is sent to a 
Carlson Software server, validated and returned in just a few seconds. If you are 
using a dial-up connection, please establish this connection before attempting to 
register. 

- Enter pre-authorized change key: If you originally chose the Fax method above, you 
will need to choose this method now to enter the change key that is faxed back to 
you. 
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- Register Later: If you wish, you may defer registration up to 30 days. After this time, 
Carlson will enter demo mode which displays a message each time a Carlson 
command is run. 

 
After you select the registration method, choose Next and select the type of installation you 
are performing, choose Next again to review the copyright information and to fill out the 
required information. At this point, if you are using the Fax method, press the Print Fax Sheet 
button. If you are registering using the Internet method, press Next and the process will start. 
The process has ended successfully when you have received your Change Key. Make sure 
your keep you serial number and change key in a safe place. 
 
Tip:  If Carlson SurveyGNSS  is running, you may access the registration dialog by 

choosing Product Registration from the Help menu. 
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3 Carlson SurveyGNSS Workflow 

 
 
The illustration below shows the general workflow for using Carlson SurveyGNSS. 
 
 

 
 
 
 
 
   
 
See below for a further explanation. 
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I : Run SurveyGNSS 

 

II : Create a new project 

Go to File and select Open to create a new project. Project files have the extension ‘.sgp’. 

 

III : Select a coordinate system 

This is an optional step. When a coordinate system is selected, the coordinates of the site 

positions in the Positions tab will be presented in the selected coordinate system. Go to 

Tools and then Set Spatial Reference… In the Define Spatial Reference window select 

your coordinate system. Note that you have to be on line to make this selection. 

 

IV : Import RINEX files 

To import RINEX (or proprietary) files select the Observations tab and drag your RINEX 
files from the data folder where you have stored the files onto the tab. When this is done you 
maybe review the sites and vectors by picking the Map tab. Note that all observations must 
be given in RINEX format (up to version 2.11) with each file containing 
data of a single receiver deployed. 

 

V :Set the position status 

Usually one of your stations will be the reference point for which the coordinates are  kept 

fixed. Go to the Positions tab, right-click on the status icon of the reference station (by default 

‘Approximate’) and change the position status to ‘known’. 

 

VI : Compute vectors 

First select the vector to compute in the Observations tab by Ctrl+left-clicking on the 

observations. The line with the selected observation will change color. Then either right-click 

and select and select Compute Vector(s) from the menu, or select Analysis>Compute 

Vectors(s) from the main menu tab. 

 

VII : Inspect results 

Go to the Vectors tab to inspect the results. Newly computed vectors will be added to the 
list. 
 
 
VIII : Export results 

Go to File>Export on the main menu bar to export the results. By default, a text file with 
detailed results about the processed vector is created in the project folder. For each vector 
there is a separate file. The filename is a combination of the station names. 
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4 Conversion of Receiver Files to RINEX 
 
SurveyGNSS support a number of proprietary GNSS receiver formats. The processing 
engine of SurveyGNSS works exclusively with RINEX files. RINEX is the Receiver 
Independent EXchange format for raw GNSS data. Therefore all proprietary GNSS files are 
converted into RINEX directly following the import. 
 
The pre-defined auto-conversion to RINEX in SurveyGNSS is only possible when the 
conversion tool from the proprietary format to RINEX is made available by the manufacturer 
for free distribution. Some RINEX converters are only available to authorized users of certain 
manufacturers’ GNSS equipment and cannot be redistributed/installed by SurveyGNSS. 
 
Open source support has been incorporated together with additional shell scripts which 
support additional proprietary receiver formats. The shell scripts are redistributed in the 
Carlson SurveyGNSS install folder sup\RINEX and take the form of standard Windows batch 
(.bat) script files. 
 
What to do if your GNSS receiver files are not in the list of supported proprietary files? 
If you have a RINEX converter, then you can convert your files to RINEX prior to running 
SurveyGNSS and then import your files as RINEX. However, to simplify the import procedure 
and to make the process more user friendly, you can now create a custom batch file which 
includes your RINEX conversion executable.  
 
For example, if you want to use the Topcon tps2rin.exe (not distributed by Carlson, only 
available to Topcon customers), follow these steps: 

 Go to the Carlson SurveyGNSS install folder sup\RINEX\sample, here you will find a 
number of sample files which you can edit and use. 

 One of the sample files is called Topcon_sampe.bat, open this file in the Windows 
editor (or any other ascii file editor). 

 Go to line number 41 and replace ‘REM’ by ‘SET’ and replace <PATH TO 
tps2rin.exe> by the folder location of your tps2rin.exe file. 

 If you have your exe file stored in the folder \tools\converter\topcon then the 
modified line should look like this: 

 
 Save and close the editor, rename the file to Topcon.bat and copy the file from the 

sample folder to sup\RINEX 

 The conversion from Topcon tps file to RINEX via tps2rin is now available in 
SurveyGNSS through File> Open  
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5 Guidelines for Evaluating Results 
 
Whether the post-processing result is acceptable depends on the accuracy which we want to 
achieve, but let’s assume we are aiming for cm-accuracy. The SurveyGNSS Vector view 
starts by listing three very basic but also very important items; baseline Length, Solution 
and Quality.  
 
Both in case of RTK and post-processing the baseline length is an important factor. When 
the baseline length increases, the influence of the ionosphere increases as well. For longer 
baselines (>20km) it will be increasingly difficult to get a fixed solution and cm precision. The 
quality of the data (cycle slips, multi-path, PDOP, number of SVs, observation time) plays a 
role in this as well. The specs of geodetic GNSS receivers usually show precision values 
such as: 5mm+1.0ppm horizontally and 10mm+1.0ppm vertically. This means that for a 
20km baselines the expected precision under good conditions will be around 2.5cm 
horizontally and 3.0cm vertically. These values are nothing more than an indication and 
require ‘good conditions’ but can be useful as a rule of thumb.  
 
We should aim for either a FixedL1 solution for short baselines (<10km) or a ionosphere 
free L0 solution for longer baselines, both with ‘high’ Quality. Then we have an optimum cm-
level result. The software will always try to compute a FixedL1 solution since this will give the 
most accurate result. The definition of ‘short baseline’ is not strict. If the quality of the data is 
sufficient, then baselines of 10km will be FixedL1. On the other hand if the quality if poor, 
baselines of just 5km will be hard to be fixed with L1 data. 
 
For long baselines the software will produce a FixedL0 solution. If the quality of the data is 
high then ‘long’ could mean 100km or more. The result will be on the cm-level, taken into 
account what is mentioned above about precision in relation to baseline length. 
 
If our solution is float (FloatDGNSS) then the software was unable to fix any ambiguities. The 
percentage of fixed ambiguities will be 0. The accuracy in this case will usually be on the dm-
level. 
 
When we have a fixed solution it is useful to check the percentage of Fixed Ambiguities. The 
higher this value the better. When our data is of high quality, this value should be well above 
95%. The percentage of Reweighted Observations on the other hand should be as low as 
possible. After ambiguity fixing all the residuals in the solution are checked for outliers. The 
large residuals are weighted lower in the final estimation process. This value is a measure of 
how well the solution fits the actual data. In case of high quality data this value should be 
close to 0.0 . 
 
The pdop value should be as low as possible. When using a modern GPS+GLONASS 
receiver which is tracking sufficient satellites, this value will be well below 3 or even 2. The 
pdop value can still be a useful parameter to monitor i.e. in a GNSS-hostile environment 
such as an urban canyon. Even while having a short baseline with a FixedL1 solution based 
on good quality data, the precision of our solution could be worse than expected because of 
the bad satellite geometry. The pdop will then increase to 6 or more.  
 
Note that the standard deviation of the rover position which is also presented (σx ,σy ,σz), is 
only a measure of the internal precision. Very often this value is over-optimistic and should 
be corrected i.e. by a factor 4 or more. A better indication of the actual precision of the rover 
positions is by carrying out a least squares adjustment. This requires a network with 
sufficient redundancy.  
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The σ0 Vector value is the standard deviation of unit weight, and is similar to the a posteriori 
standard error of unit weight in a network least squares adjustment. Ideally this value is 1.0. 
When the value is lower than 1.0 the accuracy of the solution is better than expected; the a 
priori accuracies were too pessimistic. When the value exceeds 1.0, the a priori accuracies 
were too optimistic.  
 
When using a GPS+GLONASS receiver, the GLONASS ambiguities can only be solved 
when SurveyGNSS has the correct information about the antenna and receiver type. The 
reason is that the receiver bias depends on the satellite signal frequency. All GPS satellites 
transmit on the same frequency so they all create the same receiver bias. GLONASS 
satellites transmit on different frequencies; each GLONASS satellite generates a different 
receiver bias. In technical terminology GLONASS satellites cause inter-channel biases 
which, if not taken into account, can significantly degrade position accuracy. SurveyGNSS 
will take the biases into account when it has knowledge about the receiver type.  
 
Therefore it is important that both the antenna and receiver type are listed in the RINEX 
header. For instance: 
 

4612206760          TRIMBLE NETRS       1.3-0        REC # / TYPE / VERS 
0220367016          TRM29659.00     SCIT                     ANT # / TYPE 
 

SurveyGNSS will identify the receiver by the following 3 letters: 
TRI (Trimble) 
ASH (Ashtech) 
JPS 
TPS (Topcon) 
JAV (Javad) 
LEI (Leica) 
NOV (Novatel) 
SEP (Septentrio) 
 
See also paragraph 5.3 . 
 
Everytime a baselines is successfully processed, a plain text log file of the processing is 
created (basefilename-roverfilename.txt). This file includes valuable information about the 
processing. 
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6 SurveyGNSS Main Menu 

 
See below a description of the SurveyGNSS main menu options. 

 

6.1 File menu 
 
SurveyGNSS provides a logical and easy-to-use system for creating, opening and saving  
project files.  

 
 
 
 
 
 
 
 
 
 
 
 
 

- New will create a new SurveyGNSS project. 
- Open will open an existing SurveyGNSS project or when a project is already then this 

option can be used to add data files as an alternative to drag and drop.  
- Close will close the current SurveyGNSS project. 
- Save As…offers four different file formats to save your data in: 

 
 

 
 
 
 

 The KML Encoding Standard allows you to save files in the format accepted by 
Google Earth, Google Maps and some of the Marble software.  KML became is an 
international standard of the Open Geospatial Consortium. 

 LandXML 

 Carlson CRDB is the Carlson coordinate format. This format 
allowsaalphanumeric combinations of point number and descriptions up to 255 
characters in length. 

 Carlson RW5 is Carlson’s raw data format. SurveyGNSS will store the station’s 
geographic coordinates in this format. This allows for further processing of the 
station coordinates in other Carlson products. For instance, when you need the 
position of a station to be expressed in a specific (local) coordinate system or 
geoid which is not available in SurvGNSS, then the RW5 format will be the 
exchange format to products such as Carlson SurvCE, X-port or Survey.   

- Save Adjustment allows you to accept and the adjustment results from Analysis> 
Adjust Network. 

- Recent Projects presents a list of projects that have recently been opened. 
- Exit ends SurveyGNSS and exits. 
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6.2 View menu 
 
The options in the View menu will work jointly with the four SurveyGNSS views: Map, 
Observations, Vectors and Positions. 
 

 
 
 
 
 
 
 
 
 
 
 
 

The following options are available: 
- Zoom Extent will activate the zoom extent in the Map view. This option is also 

available by right-clicking on the Map view. 
- Position Annotation… will activate a menu that allows you to change the font, size 

and color of the text on the Map view. 
- Observed Satellites works best in combination with the Observations view. This 

option will provide a graphical overview of the tracking of each observed satellites. 
This overview consist of a horizontal bar chart with each satellite observed (GPS and 
if available GLONASS), represented as a horizontal bar spanning the time during 
which the satellite was observed. Satellites are marked by their identification number. 
By analyzing the overview you can check on anomalies in your raw data (data gaps 
caused by bad tracking) that may affect the post-processing result. 
You can only view one file at the time. 

- Observation Durations shows you the overlap in observation duration between 
stations. Only stations which have overlapping observation periods are candidates for 
baselines processing. 
Make sure you select two or more stations for which you want to evaluate the overlap. 

- Collapse Observation Groups reduces the Observations view. 
- Expand Observation Groups expands the Observations view. 
- Coordinate Display allows you to change the representation of the coordinates in 

the Positions view: Geocentric, Geographic or Projected. 

 

6.3 Edit Menu 
 
The Edit menu offers the following options: 
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- Spatial Reference… allows you to select a coordinate system from the on line 

Spatial Reference List. You may us a search reference to find a suitable coordinate 
system and then pick it from the list. Exit with the OK button and the name of the 
active coordinate system will appear on the bottom right of the SurveyGNSS screen. 
See below an example for the available coordinate systems in Poland. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
Once a coordinate system is active, you may express the station coordinates in the 
Positions view in the Projected Easting, Northing, Height. 
 

- Preferences allows you to set the preferences for the processing: General, Vectors 
and Adjustment. 

 General includes Data Resources and Reference Observations. 
In Data Resources you can set the Gravity Model and the Antex file with the 
Antenna Definitions.  
The default Gravity Model is the worldwide EGM2008 model in the binary GTX 
format. Textual Carlson geoid grid files, such as the files used by Carlson 
SurvCE and SurvPC, are accepted as well. Note that when this option is 
enabled the projected coordinates presented in the Positions tab are showing 
‘orthometric’ heights. 
By default two ATX files are supplied; from the NGS (National Geodetic 
Survey) and the IGS (International GNSS Service). 
SurveyGNSS will read the antenna type and serial number from the RINEX 
header. If the antenna type is not found in the current Antex ATX file, an error 
message is displayed and the RINEX file will not be processed. To solve this, 
select an ATX file which includes the proper antenna type or edit the RINEX 
header of your observation file; go to the Observations view and right-click on 
the observation and select Observation Details (see Tutorial 4 for an 
example). 
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It is also possible to disable this option (tic Enable off). Note: disabling the 
Antenna Definition and thus not using the antenna calibration may degrade 
the accuracy of the processing result.  
In Reference Observations you can set the search range for Published 
Observations. See the Tools menu. 

 Vectors, see the Analysis menu option Compute Vector(s) With Options. 

 Adjustment. See the chapter on least squares adjustment for details. 
 

- Observation Details will show more detailed information on the observation currently 
selection in the Observations view. The displayed information is based on what is 
available in the RINEX header. Observation Details also allows you to edit the 
station position, i.e. updating the know station coordinates. 
 

- Remove will permanently delete the selected observation or vector from the project. 
 

- Position Status… allows you to change the position of a station in the Positions 
view from Known to Approximate and vice versa. 
 

- Edit Position(s)… makes it possible to edit the coordinates of a station in the 
Positions view. This is useful when the coordinates of a point in the RINEX header 
are just approximate. By using the options the coordinates of a known point can be 
updated, whether geocentric, geographic or projected.  
 

 
 

6.4 Analysis Menu 
 
The Analysis menu offers the following options: 

 

 

 

 

 

 

 

- Compute Vector(s) invokes the SurveyGNSS post-processing engine. You can only 

select and process one vector at the time. 

 

- Compute Vector(s) With Options… allows you to set a number of processing 

parameters: 

 Elevation Mask specifies the minimum mask angle in degrees to be 
used. A low angle allows the use of more satellites, but at the same time 
increases the potential of processing bad data (multipath effects and cycle slips). 
Low observations usually result in more noise. When the data is a good quality 
the mask should be between 10 and 15 degrees. Of course the mask value 
should not be lower than the mask used during data collection by the receiver. 

 Interval specifies the processing data interval to a value greater than the interval 
used during recording of the data. This options can be used to synchronize the 
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data, i.e. if the base logged at a 15 second interval and the rover at a 10 second 
interval, then the common inval value to be set is 30. 

 Constellations allows you to set a GNSS constellation. SurveyGNSS will be 
ready to process data from new GNSS systems as soon as these become 
available for commercial use. 

 Frequencies allow you to set the frequencies: L1, L1+L2  and L1+L2+L5 
(depending on the L5 availability).  

 Kinematic Position File Format defines the output of processed kinematic data 
in terms of the format of Position and Date & Time. Kinematic data is exported in 
an ascii file with the extension ‘pos’ . 

 Instantaneous Vector Processing allows you to reduce the duration of an 
observation. You can reduce the duration by typing in the From and/or To times 
or reduce the duration graphically by an overlapping rectangle. See example 
below. 

 Enable/Disable Satellites… allows you to deselect satellites individually so that 
data from these satellites will not be part of the solution.  
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- View Closures allows you to view the closure errors in your network. This options 

works best with the Map view selected, and of course only works when you have a 

closed figure (a loop) in your network. 

First select the stations which form the loop; left-click on the station symbol while 

holding the Shift key. Then select View Closures, either from the Analysis menu or 

by right-clicking and selecting View Closures from the popup menu. 

 

 

 

 

 

 

 

 

 

 

 

The closures errors (∆) are presented in x, y and z direction separately, as well as in a 

combined ∆Total value. The Relative Precision is a measure of the total closure 

error versus the Path Length. 

- Adjust Network will carry out a least-squares network adjustment. To accept the 

adjustment results and store them internally, go to File> Save Adjustment. 

Note: Every time a baselines is successfully processed, a plain text log file of the processing 
is created (basefilename-roverfilename.txt). This file includes valuable information about the 
processing. This file is displayed on the right side of the screen in Transcript tab of the 
Reports window. 
 
 

6.5 Tools Menu 
 

The Tools menu offers the following options: 
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- Search Published Control… 

- Search Published Observations… 

The options under Tools allow you to download know station coordinates in the area of your 

survey, as well as RINEX data from local active reference stations. An internet connection is 

required. Also note that this service is not available in all parts of the world. For details on the 

working of these tools see Tutorial 2. 

 

6.6 Help menu 
 

The Help menu include the SurveyGNSS ‘about’  information as well as the Product 

Registration, see also Chapter 2. 
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7 SurveyGNSS Views 
 

SurveyGNSS allows you to inspect your raw and or processed data in four different tabs or 
views. The SurveyGNSS views are: 

- Map view 
- Observations view 
- Vectors view 
- Positions view 

 

7.1 Map View 
 
The Map view presents the positions and observations on a worldwide background map. 
SurveyGNSS uses OpenStreetMap© for this purpose, a collaborative project that creates 
and distributes free geographic data for the world. An internet connection required to view 
the map. 
 
Initially only the positions of RINEX stations are shown, baseline vectors are shown after 
computation. The colors of the station symbol indicates the position status: approximate-blue 
(not yet processed), known-red, (kept fixed) and processed-yellow. See also the Positions 
View. 
 
Note that positions of kinematic points are not shown on the Map. Create a Google KML file 
via File> Save as…> Open GIS®KML Encoding Standard to view these positions. 
 
Right-clicking on the map brings up a menu with 3 options: 

 
 

- Use Zoom Extent for a complete view of you network. You can also use the ‘+’ and ‘-
‘ buttons on the top left for zooming. Your mouse can be used to zoom and pan as 
well. 

- Positions annotations brings on a standard Windows screen for changing the font 
on the station name. 

- View Closures will open a windows and show the closure errors. To view the 
closures it is necessary to define a closed figure (loop) on the map. See 
Analysis>View Closures in the main menu. 

 
 

7.2 Observations View 
 
The Observations view allows you to import RINEX and other supported observation files 

into the SurveyGNSS project. To import a file, select the filename from your Windows 

document browser and drag the file onto the Observations tab. SurveyGNSS will open a 

Report window on the right of the screen with information about the import and about the 

conversion to RINEX (in case of a proprietary observation file format). 
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If the file is accepted, SurveyGNSS will display 
information about the file and all observation files 
imported into your project. 
Observations are listed in the view along with the following information: 

- Observation shows the station name and the associated file name 
- Ephemeris shows the ephemeris file that is used, this can be the standard broadcast 

ephemeris file or file with a precise ephemeris 
- Antenna height shows the antenna height in meters found in the import file 
- Start Time shows the data and start time of the observations 
- Durations shows the duration (observations time) in hh:mm:ss 
- Measurements shows the number of measurements based on the duration and the 

measurement rate, i.e. 1 hour of data with a 15 sec rate is 60 x 4 = 240 
measurements. 

 
Right-clicking on the Observations view brings up a menu with a number of options: 

 
- Use Collapse/Expand Groups to minimize or maximize the listed observations. 
- Use Remove Observation(s) to permanently remove an observation from the 

project. First select the observation, then remove. 
- Observation Details opens an editor to edit the RINEX header details. 
- Search Published Observations…/Compute Vector(s)/Compute Vectors With 

Options… offer a quick way to access the same options under Analysis.  
 

See the View menu option for information on graphical display of observations and 
durations. 
 

 

7.3 Vectors View 
 

In the Vectors view the post-processing results are listed. By default, a text file with detailed 
results about the processed vector is created in the project folder. For each vector there is a 
separate file. The filename is a combination of the station names. 
 

See an example for the SurveyGNSS output below. 
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Under From the name of the base station in the base RINEX file is shown, under To the 
rover name is shown. 
 
From File and To File show the associated based and rover RINEX files. 
 
The antenna height in From Antenna Height/To Antenna Height should be the true 
antenna height i.e. the height from the marker on the (ground) surface to the antenna phase 
center. This is conform the RINEX specifications. 
 
The Length is the baseline length (m). The baseline length is an important factor in the 
selection of the solution type, i.e. for longer baselines an ionosphere-free solution is selected. 
This is done automatically. 
 
Each coordinate solution is accompanied by its Solution type (DGNSS, FloatDGNSS, 
FixedLW, FixedL1, FixedL2, FixedLN, FixedL0) and static solutions by a Quality indicator 
(low, medium, high).  
Solution quality "high" is only given to those FixedL1 or ionosphere-free FixedL0 solutions 
which fulfill certain requirements with respect to percentage of fixed ambiguity, standard 
deviation of unit weight, number of satellites, and PDOP. Solutions of the type FixedLW are 
always of "medium" quality.  
FloatDGNSS solutions may be either of "medium" or of "low" quality, mainly depending on 
the amount of observation data.  
The quality indicator of a DGNSS solution is always set to "low". 
 
pdop is the Position Dilution of Precision, a measure of the quality of the satellite geometry. 
 
The σ0 Vector is the standard deviation of unit weight. 
 
The σ0 Solution is the standard deviation of a single observation (m). 
 
Satellites lists the number of satellites (GPS & GLONASS). 
 
Fixed Ambiguities shows the percentage of fixed ambiguities for the data. The DGNSS or 
FloatDGNSS solutions are not included in this number. 
 
Reweighted Observations show the percentage of re-weighted observations. 
 
∆x, ∆y, ∆z are the vector elements (m) of the baseline to the rover position. 
 
The σx ,σy ,σz are the standard deviations of the rover position in Cartesian coordinates (cm). 
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ρ∆x∆y,  ρ∆x∆z, ρ∆y∆z are the correlation coefficients for the XY, YZ, ZX vector element 
combinations. 
 
Tip: Right click on one of the column headers. This will allow you to make a selection of the 

displayed items. 
 To save the view to a file or print the view, use the appropriate icon on the bottom right; 

 
 
 

7.4 Positions View 
 

The Positions view lists the stations and their coordinates as well as their status. The 

coordinates are expressed in the coordinate system which was chosen in Tools>Set Spatial 

Reference… 

Right-clicking on the status of a station will bring on a menu: 

 

 

 

 

 

 

 

 

Coordinate Display… will set the coordinates to Geocentric (Earth-centered Cartesian 

XYZ), Geographic (latitude, longitude, height) or Projected (e.g.UTM). The projected 

coordinates are based on the coordinate system projection selected in Tools>Set Spatial 

Reference… 

The Position Status… is either Known or Approximate. Usually the network will include a 

reference position will should be marked as Known. The other station are then Approximate. 

This is the default value. The known station is kept fixed in the processing, the rover position 

is processed relative to the known station. 

There is no use in marking more than one station as Known. Constraints on the network 

which are imposed by multiple known stations should be handled by the least squares 

adjustment following the post-processing. 

Edit Position(s)… can be used to edit the coordinates i.e. of a known station. The three 

position formats (geocentric, geographic, projected) in the Edit Position window are linked, 

so when making a change all formats are updated simultaneously. 
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Tip: Right click on one of the column headers. This will allow you to make a selection of the 

displayed items. 
 To save the view to a file or print the view, use the appropriate icon on the bottom right; 
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8 SurveyGNSS and SurvCE 
 

For the post-processing of stop and go surveys, SurveyGNSS assumes there is a RW5 as 

produced by SurvCE available. The RW5 file holds the markers (the ‘stop and go points’) and 

this is vital information for the processing.  

To import the rover part of a stop and go survey, the RW5 file must be dragged and dropped 

onto the Observations view. The rover raw data file is then automatically added. 

SurveyGNSS will merge the RW5 file and the rover raw data file, which could be in one of 

the supported proprietary format, into a new RINEX file. The new RINEX file now includes 

the stop and go markers.  

The new RINEX file should also import information about the antenna type from the 

proprietary log file. If this info is not available (e.g. not entered in SurvCE or the log file has 

no record for the antenna type) then SurveyGNSS will generate a [502]: No APC-corrections 

error message: 

 

 In this case the antenna type must be picked manually from a predefined list. This is 

important for a correct processing of the offset to the antenna phase center. See Tutorial 4 

for an example. 

Some receiver brands might produce RINEX files which already hold the stop and go 

markers. There is no guarantee that these RINEX files are accepted by SurveyGNSS. 

See the Carlson SurvCE Reference Manual for further information about logging raw data 

from your GNSS receiver for post-processing. Note that this option is not supported for all 

receiver brands.  
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Note that in SurvCE 4.0 new records have been introduced to facilitate the processing of raw 

data: GNSSLOGRCVR and GNSSLOGANT. When using SurvCE for static or kinematic 

datalogging in the receiver, it is advised to use SurvCE 4.0 . Carlson cannot guarantee 

proper import results of raw data with SurvCE 2.x and 3.x . 

See an example of the use of the new records in a SurvCE 4.0 RW5 file below: 

--GPS Log File: 1802rov.log rover open Carlson,Surveyor+ GPS 

--GNSSLOGRCVR,FL1802rov.log,SRROVER,RNBFN12100140 

D2LR0G55R,RMNOVSurveyor+ GPS,RFOEM060100RN0000 2011/Jun/28 

--GNSSLOGANT,FL01802rov.log,AN,AMNOV702GG        NONE,LI1000,AG2.000,PA0.067 

--GPS Log File: 1802rov.log rover close Carlson,Surveyor+ GPS 
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9 Least Squares Adjustment 
 
SurveyGNSS includes an adjustment tool, based on SurvNet, Carlson's network least 
squares adjustment program. This tool performs a least squares adjustment 
and statistical analysis on a network of known points and GNSS vectors (total station 
measurements not included).  
 
The preferences for the adjustment are found under Edit> Preferences.  

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
The General Section includes: 
 

- Confidence Level: This setting is used when calculating the size of error ellipses, 
and in the Chi-square testing. 

 
- Convergence Limit: The adjustment is carried out in a series of converging 

iterations. During each iteration corrections are computed. When the corrections are 
below the convergence limit, we have found our solution.  

 
- Iteration Limit: This settings defines the maximum number of iterations of the 

adjustment process. The iteration process is stopped when either the convergence 
limit or the iteration limit has been reached. A high number of iterations could indicate 
bad data (slow or in extreme case no convergence). Typically if there are no blunders 
in the data the solution will converge in less than 5 iterations. 

 
- Centering error: This option is used to specify the precision associated with 

centering a GPS receiver over a marker. 
 
The GNSS Vector Weighting presents three options for settings the a priori standard 
precision of the vectors. The three vector elements DX, DY, DZ are correlated so we are 
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actually dealing with a full 3x3 matrix including the off-diagonal correlation coefficients. The 
standard deviation of the rover position calculated by the post-processing is only a measure 
of the internal precision. Very often this value is over-optimistic which results in incorrect 
weighting in the adjustment. Incorrect weights will make the statistical testing unreliable. 
 

- By selecting Variance Factor  and entering an A Priori Variance Factor value, we 
are scaling the a priori precision to  a more realistic value. It is not uncommon to scale 
the standard deviations by a factor 4 or 5 or even more (16 or 25 Variance Factor). 
This methods works well when all vectors are equally over-optimistic, i.e. when all 
vectors are of similar length. 
 

- By selecting Standard Deviation, the precision of the vectors is subject to the 
entered values for the A Priori Standard Deviation model (i.e. 5ppm + 1 ppm).  This 
model is in line with what most GNSS receiver manufacturers list in their specs as 
static performance. This methods works well when the network includes vectors of 
various lengths. The drawback of this model is that the correlation between the vector 
elements is ignored. This simplification might influence the reliability of the statistical 
testing. 
 

- The Standard Deviation Scale method is a combination of the two methods above. 
The ‘mm + ppm’ model is used to set the a priori precision and then each vector is 
scaled individually to this model value. This is a more refined method compared to 
the Variance Factor method which applies a single scale factor to the complete 
network. The advantage over the A Priori Standard Deviation model is that 
correlations are taken into account.  
 

The adjustment will Compute Relative Ellipses for stations which are within a certain 
distance of each other. The distance can be entered in the Stations Within field. 
 
SurveyGNSS uses the Chi-square test for the statistical testing. This is a so called overall 

model test which does not test individual observations, but either accepts or rejects our 

complete network. Simply said: the null-hypothesis which is tested is H0: our network is 

correct. Correct means that: 

- The a priori standard deviations for our vectors have been correctly estimated; they 

all have realistic values.  

- The model chosen to relate the observations to the unknowns parameters (station 

coordinates) is complete an true, and the vectors are free of bad observations 

(outliers). 
 

When the Chi-square test is accepted, we can accept the processed positions with the 

option under the File menu; File> Save Adjustment. Then for each new position in the 

Position View, the a posteriori standard deviations σx, σy, σz and their correlations ρxy, ρxz, 

ρyz are added. In the Observations View for each vector the least squares corrections vΔx, 

vΔy, vΔz and the normalized or standard residuals nvΔx, nvΔy, nvΔz are added. Ideally, the 

latter values should be close to 1.0 . 

On the other hand, if we have a rejected Chi-square test, we must go back to our GNSS 

vector weighting, or go back to our post-processing result. When we are able to identify a 
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suspect vector in our post-processing results we have the option to re-process, to remove (if 

we have enough redundancy) to re-measure the vector. 
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10 Tutorials 

10.1 Tutorial 1: Processing Static Data 
 

In this tutorial you will process 2 baselines with SurveyGNSS and will learn about the basic 

settings in the software. An internet connection is required. 

 

1. Start SurveyGNSS and select File > New to open a new project. SurveyGNSS 

projects will have the extension ‘sgp’ . Call the project ‘ppstatic’ or another 

appropriate name. 

 
 

2. We will import 3 static files. To import a file, select the filename from your Windows 

document browser and drag the file onto the Observations tab. 

 
Import all three files: C11.13O, 39G001.13O, M4010001.13O . Note that you only 

have to import the RINEX ’O’ files; the associated files will be added automatically. 

Your screen should look like this: 
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3. To review the location of the three markers go to the Map tab. Right-click on the map 

and select Zoom Extent. 

 
The sample data that we use is this tutorial is in the South-East of Turkey. 

 

4. The next step is to select a plane coordinate system. Go to Edit>Spatial 

Reference… This will bring you to an online database of coordinate systems. In this 

tutorial we will use a standard UTM projection; in the Search References Field enter 

‘UTM Zone 37N’ and then select Search. Pick the coordinate system from the list 

(7771) and select OK. 

In the bottom right of the screen you should now see the selected coordinate system. 

This coordinate system is now active. 

 
 

5. Now go to the Positions tab. By default the coordinate system displayed is 

Geocentric (XYZ, Earth-centered). Right-click on the blue triangle, select Coordinate 

Display… and then Projected. Now you will see the coordinates displayed in UTM 

projection. 
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One of the markers will be our reference point, the position of the other two markers 

will be calculated from this fixed reference point which we assume to be known. 

Marker C1/1 will be our reference point; right-click again on the blue triangle and 

select Position Status… > Known. 

 

6. We have now entered some basic settings for the processing but we have not yet 

looked at our data. Go back to the Observations tab. From the main menu select 

View> Observed Satellites. Now pick C1/1, our reference station, by left-clicking on 

the line with the filenames while pressing the Ctrl key (make sure the observation 

groups are expanded). The selected line will change color and on the right side of the 

screen a graphics overview of the observed satellites is shown. 

 

The view can be expanded by dragging the display window to the left. Our data looks 

good: we a combination of GPS and GLONASS data and the apart from a view cycles 
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slips (sections where the colored lines are broken) the quality seems satisfactory. You 

can review the data of the other files as well.   

Another useful display is the observation durations; this will show how much overlap 

we have between our files. If we have no overlap or the overlap is too short, the data 

processing will fail. From the main menu select View> Observation Durations. Now 

pick all three observation lines by left-clicking while pressing the Ctrl key. The graph 

will show that we have overlapping data for about an hour which should be sufficient 

for our baselines. In the Observations tab you can also review the duration of the 

observation and also the number of measurements. The data was taken at a 15 

second rate so in our case we have well over 240 measurements for each file. 

 

7. Now we are ready for the actual processing of the data. In the Observations tab 

select C1/1 and 39G0001. Go to Analysis in the main menu and select Compute 

vector(s).  

 
 

Go to the Map tab and note that a baselines is now drawn from C1/1 to 39G0001. 

Then go to the Vectors tab to review the processing result. As you can see we have 

37km baselines with a FixedL0 solution of high quality. 

 
 



 
 

SurveyGNSSTM UserGuide 31 Carlsonsw.com 
 

Now process the other baseline: C1/1 to M4010001. 

 

8. A text file with details of the processing is created for every processed baseline in the 

data folder of the RINEX files. The files are named after the markers, so in this case 

look for the files C11-39G0001.txt and C11-M4010001.txt . 

To save the processed positions you can create a Carlson CRDB file (for further 

processing with Carlson office products) via File> Save As..>Carlson CRDB 

  
 

It is also possible to create printer output, a HTML file or a Word Doc using the 

buttons on the lower left. 

 

 

Tip: To control which parameters are to be send to the printer/Doc/HTML, position the 

mouse on one of the column headers (in either the Observations, Vectors or 

Positions tab) and right-click. This will bring on a set of tic boxes which let you switch 

parameter on or off.  
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10.2 Tutorial 2: Downloading active and passive reference stations 
 

In this tutorial you will download RINEX data from reference stations near your base and 

rover points. You will also locate control points in your area. Reference stations which 

produce live RINEX data are referred to as active stations, while known points (i.e. first or 

second order control points) are called passive stations. For this tutorial an internet 

connection is required. 

 

1. Start SurveyGNSS and select File > New to open a new project. SurveyGNSS 

projects will have the extension ‘sgp’ . Call the project ‘Activestat’ or another 

appropriate name (see also Tutorial 1). 

 

2. We will import a single static file and then add data from 3 active stations. Drag the 

file BOB1196A.13O from you Windows browser to the Observations tab in 

SurveyGNSS. 

 

3. Go to the Map tab and Right-click on the map and select Zoom Extent. 

 
Our station BOB1 is located in Connecticut, north of New Haven. 

 

You may skip Step 4 when you are not interested in passive published control points 

and to go directly to CORS station selection. 

  

4. We would like to find control points in our area. We can use these points as base 

stations for our own GNSS receiver, or add one or more points to our network for QA. 

Go to Tools>Search Public Control… You will see a map of the U.S. (more active 

reference networks will be added to SurveyGNSS at a later stage). Follow the given 

guideline: Zoom to maximum 2°x 2° x area of interest…  
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Once you have zoomed to an acceptable level, select GNSS Only as the type of 

control point, and then press Search for Control. 

The number of located stations depends on your zoom-level. For the 0.38° x 0.18° 

area above, 8 stations were found.   

 

Left-click on the station near Route 70. You will see it has the identifier DG5871. 

When you close the pop up, you will note that a tab DG5871 has been created. In the 

tab you will find the NGS data sheet with full information about the control point. 
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When you exit the DG5871 tab by pressing OK, the control point will be added to the 

project as a known point. This was merely an illustration of the use of passive control 

points. We will not use this point in this tutorial. 

 

5. We will now locate the active stations (CORS) near our BOB1 marker. We will search 

in a radius of 105km. This radius exceeds the 100km default, so go to Edit> 

Preferences… and then change the Proximity value under General Settings to 

105km.  

Make sure you have the BOB1 observation selected in the Observations tab (with 

Ctrl-left click). This observation will be the center of the search area. Now go to 

Tools>Search Published Observations… A list of available reference stations 

around BOB1 is presented. The list is sorted by distance to BOB1. 

 
 

6. Right-click on one of the stations and then select Acquire to bring in the RINEX file 

from that station. SurveyGNSS will automatically make sure that the correct data, 

time and observation interval is chosen. Select the stations CTNE at 24.0km, CTGU 

at 26.5km and LAMT at 103.4km. The LAMT station exceeds the 100km default 

search range. If this station is not in the list, go to to Edit> Preferences… and then 

change the Proximity value under General Settings to 105km.  

When you download a station RINEX file the Status field will show a green bar 

showing progress. 

 

7. After downloading the data from the 3 reference stations, we now have 4 occupations 

and our Map should look like this: 

 
Note that the reference stations are automatically marked as Known (in red).  
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8. Go back to the Observations tab and select the observations to BOB1 one by one. 

Process each observation with Analysis>Compute Vector(s). 

 

9. Go to the Vectors tab and review the processing result. Even the long 100km 

baseline is fixed with more than 99% of fixed ambiguities. This indicates high quality 

data. 

 
 

The network configuration is a typical resection. The next step is to carry out a least-

squared adjustment, See Tutorial 3. 
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10.3 Tutorial 3: Least Squares Adjustment 
 

In this tutorial you will carry out a least squares adjustment using the processed baselines 

from Tutorial 2. 

 

1. In Tutorial 2 we have concentrated on processing the raw data. For this purpose it is 

not required to have a plane coordinate system active. Now that we want to calculate 

the final position of our new station we need a coordinate system. Go to Edit> 

Spatial Reference, search ‘Connecticut’ and pick ‘EPSG:26956: 

NAD83/Connecticut’. Exit the screen with OK. 

 

2. Go to the Positions view and right-click on one of the yellow or red status icons 

(triangle). Then select Coordinate Display…> Projected  Your view will look like 

this: 

 

 
 

Note that the heights are either ellipsoidal heights or if a Gravity Model has been 

enabled under Edit> Preferences…> General . 

The reference station coordinates have all been marked as known (red); these 

stations will be kept fixed in the adjustment. Station status of BOB1 is now yellow 

instead of blue. This which means it has been processed but is not yet adjusted. 

 

3. Go to Edit> Preferences… and then to Adjustment. This will open the windows with 

settings for the adjustment. We will leave the General settings as they are (see 

below). The GNSS Vector Weighting setting is an important setting because we 

need realistic precision values for our input observations in order to achieve a realistic 

precision for our adjusted coordinates. The precision values (the 3x3 covariance 

matrix) from the post-processing are often over-optimistic and require a correction. In 

this case we will introduce a Variance Factor of 32 to scale the precision of our 

vectors.  Our correlation coefficients will stay intact. See the required settings below. 
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4. Select OK to leave the Adjustment window and go to the Vectors view and select all 

3 vectors. Then go to Analysis> Adjust Network.  

 

SurveyGNSS will present the results in the Least Squares Adjustment Summary 

below. The Chi-square statistical test has accepted our model.  

5. Now go back to Edit> Preferences…> Adjustment . Change the Variance Factor 

value to 25, and rerun the adjustment; Analysis> Adjust Vectors.  

If you check the Least Squares Adjustment Summary you will see that the Chi-

square test has now failed. By decreasing the variance factor to 25 we are too 

optimistic in describing the accuracy of our input data. Set the factor back to 32, rerun 

the adjustment. To accept the adjustment result select File> Save Adjustment. 

Note that the Chi-square will also fail when observations are incorrect or the network 

contains a blunder. In that case increasing the factor is not a proper solution. A better 
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scenario is to try to identify a faulty observation or known station and rerun the 

adjustment.  

 

6. Go to the Positions view. The status icon of BOB1 has now turned green, indicating 

we have an accepted adjustment result. 

 
 

The indicated standard deviations are well below 3cm. If we take as a rule of thumb 

that are baseline accuracy will be around 1cm+1ppm, then with baselines of around 

25 and 100km ( 3.5cm and 6.0cm respectively) we have a proper result. 

 

7. Go to File>Save As…Carlson RW5 and select a name for the RW5 file i.e. BOB1. 

You have now created a RW5 file with geographical coordinates for the station points. 

The RW5 file can serve as an exchange format to other Carlson Software products.  

For example, to change the ellipsoidal height to orthometric (leveling) heights and to 

change the units from meters to feet, import the RW5 file in Carlson X-port and 

process with the settings below. 
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10.4 Tutorial 4: Processing of Stop and Go Data  
 

In this tutorial you will process data from a Stop and Go survey that was carried out with 

Carlson SurvCE. 

1. Start SurveyGNSS and select File > New to open a new project. SurveyGNSS 

projects will have the extension ‘sgp’ . Call the project ‘SNGsurvey’ or another 

appropriate name. 

 
2. We will import the base and rover file. The base file is in RINEX format. Drag the file 

1809base.13O from your Windows browser to the Observations tab in SurveyGNSS. 

The rover part of the stop and go data consists of the SurvCE RW5 file and the rover 

raw data LOG file in a proprietary format. Drag and drop the 1802rov.RW5 file onto 

the Observations tab, the rover raw data file is now automatically loaded. 

 

3. Go to the Positions tab. You should see a base point and 41 rover points with their 

descriptions. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Right-click on the Status icon of the 1809base station and change the Position 

Status… to Known. This will change the icon from blue to red. 

 



 
 

SurveyGNSSTM UserGuide 41 Carlsonsw.com 
 

4. To set the plane coordinate system, go to Edit> Spatial Reference… . This will bring 

you to an online database of coordinate systems. In this tutorial we will use a 

standard UTM projection; in the Search References Field enter ‘31N’ and then select 

Search. Pick the ‘ETRS /UTM zone 31N’ coordinate system from the list 

(EPSG25831) and select OK. 

 

Right-click on any blue triangle, select Coordinate Display… and then Projected. 

Now you will see the coordinates displayed in UTM projection. 

 

On the bottom right of the screen you should now see the selected UTM coordinate 

system. This coordinate system is now active. 

 

5. Let’s assume that during the stop and go survey we only had approximate 

coordinates for our base point, and that we now have more precise coordinates 

available. We want to edit the base position and enter the known coordinates. 

In the Positions view righty click on the Status icon of the 1809base station and 

select Edit Position(s)…  

In the Edit Position window, change the projected coordinates to: 

Northing:  5806070.750m 

Easting:  650614.600m 

Height:  -2,800m (Ortho) 

Exit with Save.  

Note that the for the actual post-processing in the next step, the new base 

coordinates will be used, but the base RINEX file header is not updated. 

 
 

6. In the Observations tab, Ctrl-left click on ‘1802rov.13O’ below the first stop and go 

point (point 1000) and then right-click to bring up the menu. Select Observation 

Details from the menu. The Observation Details window will open at the bottom of 

the screen. It is important for the processing that the correct rover antenna type is 

known so that the correct height offset is applied. Scroll down to Antenna Type and 

select ‘NOV702GG  None’, then Save Changes and exit.  
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7. Make sure the base station observation at the bottom of the observations list is  

selected as well by Ctrl-left clicking. Now both the base station and the first stop and 

go point are selected (to process all stop and go points only the first points needs to 

be selected).  Right-click to bring up the menu and pick Compute Vector(s). 

 

8. Go to the Vectors tab to review the processing result. All the stop and go points have 

a fixed solution and high quality. If you don’t get a fixed solution, go to 

Edit>Preferences… and make sure that the Elevations Mask under Vectors is 15 

deg and run Compute Vector(s) again. 

 

9. Go to the Map view 

and right-click to 

select Zoom Extent. 

You will see the 

cluster of stop and go 

points, all marked 

yellow (successfully 

processed). 
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10. Go to the File menu and select Save As… and then either the Carlson CRDB or 

RW5 format. 

 

 

 

 

 

 

 

 

 

The CRDB and RW5 format can now be imported in Carlson Survey and then 

processed by Field to Finish. The result will then look like this: 
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Tip: It is possible to process this file as a kinematic survey. In a Stop and Go survey 

(sometimes called semi-kinematic) there is a position calculated for all rover points in 

the RW5 file. In a kinematic survey there is a position created for every epoch; when 

the observation rate is 1 second (as in this example) then a position is calculated for 

every second. 

 Remove the RW5 file from the data folder and drag and drop the 1802rov.LOG file 

onto the Observations tab. Note that you now see an observation every second in 

the Observations tab and the point number is replaced by a date-and-time indicator. 

Process as before by Compute Vector(s).  The kinematic data is stored in an output 

file with the extension ‘.pos’ . 


